Июл 21, 2016 - 0 Comments - Интересно -

Корректирующие выпуски PHP 5.5.38 и 7.0.9. Первая бета-версия PHP 7.1

Опубликованы корректирующие выпуски языка программирования PHP 7.0.9 и 5.5.38, в которых внесено 34 изменения, в том числе устранено несколько уязвимостей. В частности, устранена уязвимость Httpoxy, позволяющая организовать MITM-атаку через манипуляции с http-заголовком «Proxy». Кроме того, устранены переполнения буфера в функции virtual_file_ex и расширениях curl, XMLRPC, Session, Zips и mcrypt, разыменования нулевого указателя в расширении Exif, серия уязвимостей в библиотеке GD и обращение к памяти после её освобождения в SNMP и MBString.

В то же время опубликован первый бета-выпуск новой ветки PHP 7.1. По сравнению с прошлым альфа-выпуском в бета-версии добавлена возможность асинхронной обработки сигналов в ext/pcntl и поддержка дополнительного контекста в обработчике pcntl_signal.

Let’s block ads! (Why?)


Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Человек ? *