Дек 19, 2014 - 0 Comments - Интересно -

Обновление PHP 5.6.4, 5.4.36 и 5.5.20 с устранением уязвимостей

Доступны корректирующие выпуски языка программирования PHP — 5.6.4, 5.5.20 и 5.4.36, в которых устранены две уязвимости в коде распаковки сериализированных данных. Первая проблема (CVE-2014-8142) может привести к разыменованию указателя NULL и краху интерпретатора. Вторая уязвимость вызвана обращением к уже освобождённому блоку данных (Use after free) и теоретически может быть использована для выполнения кода атакующего при обработке функцией unserialize() специально оформленных внешних данных. Кроме того, в выпуске 5.6.4 исправлено 26 ошибок.


Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Человек ? *