Окт 09, 2015 - 0 Comments - Интересно -

Debian прекращает поддержку стандарта Linux Standard Base

Разработчики Debian поставили под сомнение целесообразность обеспечения поддержки в дистрибутиве стандарта Linux Standard Base (LSB), который определяет сервиcы, средства разработки, бинарные интерфейсы и библиотеки, дающие возможность выполнения в дистрибутиве LSB-совместимых сторонних приложений. По мнению некоторых разработчиков, на обеспечение совместимости с LSB тратится слишком много сил, при неочевидной пользе от такой совместимости.

Поддерживаемый в Debian стандарт LSB 4.1 описывает 1493 компонентов, 1672 библиотек, 38491 команд, 30176 классов и 716202 интерфейсов. В LSB 5.0 число требований возросло. При том, что в настоящее время на предмет совместимости с LSB сертифицировано всего 8 (восемь) приложений из которых только одна программа сертифицирована на соответствие LSB 4.0+. Иначе говоря, вся огромная работа и те рамки в которые приходится укладываться ради совместимости с LSB делаются ради нескольких проприетарных программ.

Главной же проблемой является то, что никто из разработчиков не хочет брать на себя работу по сопровождению пакетов с компонентами для поддержки LSB. В связи с этим решено сохранить только пакеты lsb-base и lsb-release с небольшим набором shell-функций для скриптов инициализации и утилитой для вывода уровня совместимости с LSB, отбросив всё остальное.

This entry passed through the Full-Text RSS service — if this is your content and you’re reading it on someone else’s site, please read the FAQ at fivefilters.org/content-only/faq.php#publishers.


Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Человек ? *