Янв 28, 2016 - 0 Comments - Интересно -

Oracle прекратит поставку браузерного плагина в Java 9

28.01.2016 10:54 Oracle прекратит поставку браузерного плагина в Java 9

Компания Oracle приняла решение прекратить разработку, поддержку и поставку браузерного плагина в следующей версии Java SE. Плагин не будет включён в выпуски Oracle JDK 9 и JRE 9, которые ожидаются 23 марта 2017 года. Вместо встраивания Java-апплетов в web-страницы разработчикам сайтов рекомендуется перейти на использование технологии запуска аплетов Java Web Start, которая не требует наличия установленного в браузере Java-плагина.

Прекращение поставки браузерного плагина обусловлено движением разработчиков браузеров в сторону отказа от поддержки интерфейса NPAPI. В частности, поддержка NPAPI-плагинов уже прекращена начиная с выпуска Chrome 45. В Firefox до конца 2016 года запланировано блокирование работы всех NPAPI-плагинов кроме Flash. Microsoft Edge изначально не поддерживает NPAPI.

Кроме Java, из остающихся в обиходе NPAPI-плагинов выделяются только Flash, Unity и Silverlight. Поддержка контента на Flash сохранена благодаря портированию Flash-плагина на PPAPI (Pepper API) и применению обходных путей для его выполнения. Silverlight уже давно не развивается компанией Microsoft и объявлен устаревшей технологией. Поддержка плагина Unity будет прекращена начиная с выпуска Unity 5.4, намеченного на март 2016 года (разработчикам браузерных игр рекомендовано перейти на WebGL и штатный Web API).

  1. Главная ссылка к новости (https://blogs.oracle.com/java-…)
  2. OpenNews: Java 9 переносится на 2017 год
  3. OpenNews: Обнародован график подготовки Java 9
  4. OpenNews: Обновление Java SE 8 Update 20. Новшества Java 9
  5. OpenNews: Google представил план окончательного прекращения поддержки NPAPI-плагинов в Chrome
  6. OpenNews: Firefox прекращает поддержку плагинов NPAPI, за исключением Adobe Flash
Тип: К сведению
Ключевые слова: java, npapi, plugin, (найти похожие документы)
При перепечатке указание ссылки на opennet.ru обязательно
 
+7 +/
>Прекращение поставки браузерного плагина обусловлен движением разработчиков браузеров

Вот. Даже Оракл шевелится, а местные аналитики говорили (при обсуждении отказа от какого-то устаревшего способа шифрования), что разработчики браузеров жалкие рабы, полностью зависят от Ынтерпрайза и те, кто попрёт поперёк, будут просто невостребованы.

 
 
 
 
+7 +/
> А что ему сделается? Жив, жил и будет жить.

Ага. Выкинет поддержку всег плагинов, закроет установку неподписанных обновлений, затем подписанных, ну а затем уже и об отказе от поддержки HTML можно будет подумать и заменить его на средство для прожига дисков, допустим.

 
 
 
 
+6 +/
И идиоты пользующиеся клиент-банками, и идиоты пользующиеся системами видеонаблюдения. Все должны страдать.

Пойду выпью смузи и поиграю в энгрибёрдз на ипаде без жабки.

 
 
+1 +/
> Расскажи это писателям клиент-банков.

ну вот оракл им и расскажет.

> Браузеры не умеют в нормальную криптографию.

десять лет уже как умеют, последние два года — существенно лучше жабьей (в виду страдания последней детскими болезнями).
Для писателей клиент-банков, возможно, есть другие преимущества (браузеронезависимый доступ к локальной файловой системе, интерфейсы с косорукими аппаратными ключами и т п), но им пора уже и вылезать из браузера — jnlp никто не отменяет, и для данной цели stand-alone жабья апликуха только лучше.

 
 
+/
>> десять лет уже как умеют, последние два года — существенно лучше жабьей (в виду страдания последней детскими болезнями).

На секундочку: браузеры уже научились работать с хардварными токенами с неизвлекаемыми ключами? Или «пароля хватит всем» ?

 
+/
Я вот тоже все переживал на предмет того, как же я теперь буду клиент-банком пользоваться (у меня Приватбанк). А они, пока еще поддерживая java плагин, уже разродились альтернативным плагином (cryptoplugin называется). Я так понимаю, это их самописная штука. Что радует, ее можно установить с правами простого юзера. Теперь в Firefox можно хоть джавой, хоть этим плагином пользоваться для подписи платежек. Так что Приватбанк уже подготовил альтернативу джаве.
 
+1 +/
Эти «хорошие» люди думают, что есть не только игры в интернете, но и IntrAnet, где куча старово софта, куча старово железа с управлением через Web Java?
Кто знает есть браузер который пилят для IntrAnet’а?
Где безопасность побоку, но все по максимуму работает.
 
 
+/
> Эти «хорошие» люди думают, что есть не только игры в интернете, но
> и IntrAnet, где куча старово софта, куча старово железа с управлением
> через Web Java?

jnlp и плагины — как бы две разные сущности. Первую оракл пока не отменял. Вторая используется довольно редко (у меня вот есть небольшой кусочек внутри цискиного монстра (prime), но он давно уже не работает с той версией, с которой работают нужные мне его части)
Кроме того, прекрасный «cтарый софт» обычно требует какую-нибудь java 5.14.5-18, шаг вправо/влево — «socket error».

 
 
 
+/
> Банки перепишут свои безнадёжно устаревшие веб-клиенты, у них просто не останется другого
> выхода.

бггг. что проще переписать аппликуху или повесить на стартовой страничке предупреждение «Для работы с приложением требуется только IE6, в других браузерах функционал цифровой подписи будет недоступен»

protip банки получают доход не с продаж веб-клиентов

 
+/
Ну да, апплетам конец, флэш следующий, в общем, давно к этому шло.

а в интранете для специфических задач, где безопасность побоку, можно и старую какую нибудь сборку браузера/java использовать, наверное. Если весь софт к старому железу без исходников и перекомпиляции не подлежит.

Интересно, что будет с MIT-овским учебным языком программирования Scratch, для первой версии которого есть распространение написанных на нём игр и приложений в интернете через java-аплет, а вторая переписана на флэше…  Впрочем у мня давно руки чешутся первый Скрэтч форкнуть, а тут и повод хороший есть.

 
+1 +/
Недавно в обновлениях dev-java/icedtea-bin приехал webstart по дефолту в USE

Если icedtea оставит поддержку браузерного плагина (а скорее всего так и будет), то популярность вырастет в разы…

 
+3 +/
как обычно, опеннетовский автор не умеет в английский.

Oracle plans to deprecate the Java browser plugin in JDK 9 != Oracle прекратит поставку браузерного плагина в Java 9

Oracle plans to deprecate the Java browser plugin in JDK 9.

The deprecated plugin technology will be completely removed from the Oracle Java
Development Kit (JDK) and Java Runtime Environment (JRE) in a future Java release
TBD.

ну в общем отказ от NPAPI был на стене ОТАКИМИ БУКВАМИ еще с момента когда гугль решил запилить свой плугин с отладчиком и сотрудницами техподдержки (и напихать в бровзер еще больше ненужного говнища).

не проблема. предприятия которым хватает гугльдоков вообще не поймут о чем речь конторам покрупнее не проблема прибить браузер и плугин гвоздями.

в любом случае есть время года три-четыре подумать и смигрировать.

походу там в оракловском блоге им видимо насовали полную панамку уев потому что каменты к записи закрыты.

 
+/
>Кроме Java, из остающихся в обиходе NPAPI-плагинов выделяются только Flash, Unity и Silverlight

Google Talk Plugin забыли. Без него в firefox видео в hangouts до сих пор не работает. В Chrome оно работает через NaCl.

 
+/
а я думал Unity — это вирус…
html5 похоже не только флеш убила насовсем, но джаву…
8я джава уже в том же СУФД тормозит не по детски, представляю как 9ка будет тормозить.. Опреденно нужно казначейству уходить от джавы и опять возвращаться к  обычным приложениям и снова получить проблему обновлений на стороне клиента
 

Ваш комментарий
 

This entry passed through the Full-Text RSS service — if this is your content and you’re reading it on someone else’s site, please read the FAQ at fivefilters.org/content-only/faq.php#publishers.


Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Человек ? *